R1

R1(config)# router eigrp 1
R1(config-router)# network 172.16.1.0 0.0.0.255
R1(config-router)# network 172.16.3.0 0.0.0.3
R1(config-router)# network 192.168.10.4 0.0.0.3
R1(config-router)# passive-interface g0/0
R1(config-router)# no auto-summary

R2

R2(config)# router eigrp 1
R2(config-router)# network 172.16.2.0 0.0.0.255
R2(config-router)# network 172.16.3.0 0.0.0.3
R2(config-router)# network 192.168.10.8 0.0.0.3
R2(config-router)# passive-interface g0/0
R2(config-router)# no auto-summary

R3

R3(config)# router eigrp 1
R3(config-router)# network 192.168.1.0 0.0.0.255
R3(config-router)# network 192.168.10.4 0.0.0.3
R3(config-router)# network 192.168.10.8 0.0.0.3
R3(config-router)#passive-interface g0/0
R3(config-router)#no auto-summary

Troubleshooting

R3# show ip eigrp neighbors
#  CCNA3