CCNA3 2.3.2.3 PVST 2017-11-19

On each switch

Create VLANs

S1(config)# vlan 10
S1(config)# vlan 20
S1(config)# vlan 30
S1(config)# vlan 40
S1(config)# vlan 50
S1(config)# vlan 60
S1(config)# vlan 70
S1(config)# vlan 80
S1(config)# vlan 99

Create trunks

S1(config)# interface range f0/1-4
S1(config-if-range)# switchport mode trunk
S1(config-if-range)# switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99
S1(config-if-range)# switchport native vlan 99

S1

Configure VLANs

S1(config)# int vlan 99
S1(config-if)# 172.31.99.1 255.255.255.0
S1(config)#int f0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 30
S1(config-if)# no shutdown

Configure STP mode

S1(config)# spanning-tree mode pvst
S1(config)# spanning-tree portfast default
S1(config)# spanning-tree vlan 1,10,30,50,70 root primary

Configure PortFast and BPDU Guard

S1(config)# int f0/6
S1(config-if)# spanning-tree portfast
S1(config-if)# spanning-tree bpduguard enable

S2

Configure VLANs

S2(config)# int vlan 99
S2(config-if)# ip add 172.31.99.2 255.255.255.0
S2(config)#int f0/18
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if)# no shutdown

Configure STP mode

S2(config)# spanning-tree mode pvst
S2(config)# spanning-tree portfast default
S2(config)# spanning-tree vlan 1,10,20,30,40,50,60,70,80,99 root secondary

Configure PortFast and PDU Guard

S2(config)# int f0/18
S2(config-if)# spanning-tree portfast
S2(config-if)# spanning-tree bpduguard enable

S3

Configure VLANs

S3(config)# int vlan 99
S3(config-if)# ip add 172.31.99.3 255.255.255.0
S3(config)# int f0/11
S3(config-if)# switchport mode access
S3(config-if)# switchport access vlan 10
S3(config-if)# no shutdown

Configure STP mode

S3(config)# spanning-tree mode pvst
S3(config)# spanning-tree portfast default
S3(config)# spanning-tree vlan 20,40,60,80,99 root primary

Configure PortFast and BPDU Guard

S3(config)# int f0/11
S3(config-if)# spanning-tree portfast
S3(config-if)# spanning-tree bpduguard enable
#  CCNA3