CCNA3 2.3.1.5 PVST 2017-11-01

On each switch (S1-3)

S1(config)# no ip domain-lookup
S1(config)# enable secret class
S1(config)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login
S1(config)# line c 0
S1(config-line)# logging synchronous
S1(config)# int r f0/1-24, g0/1-2
S1(config-if-range)# sh
S1(config)# vlan 10
S1(config-vlan)# name User
S1(config-vlan)# name Management
S1(config)# int r f0/1, f0/3
S1(config-if-range)# switchport mode trunk
S1(config-if-range)# switchport trunk native vlan 99
S1(config-if-range)# no sh

S1

S1(config)# interface vlan 99
S1(config-if)# ip address 192.168.1.11 255.255.255.0
S1(config)# int f0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config-if)# spanning-tree portfast
S1(config-if)# spanning-tree bpduguard enable
S1(config-if)# no sh
S1(config)# spanning-tree vlan 1,10,99 root secondary
S1(config)# spanning-tree mode rapid-pvst

S2

S2(config-if)# int vlan 99
S2(config-if)# ip address 192.168.1.12 255.255.255.0
S2(config)# spanning-tree vlan 1,10,99 root primary
S2(config)# spanning-tree mode rapid-pvst

S3

S3(config-if)# interface vlan 99
S3(config-if)# ip address 192.168.1.13 255.255.255.0
S3(config)# int f0/18
S3(config-if)# switchport mode access
S3(config-if)# switchport access vlan 10
S3(config-if)# spanning-tree portfast
S3(config-if)# spanning-tree bpduguard enable
S3(config-if)# no sh
S3(config)# spanning-tree mode rapid-pvst
#  CCNA3