RA

RA(config)# int g0/0
RA(config-if)# ip add 172.31.0.1 255.255.254.0
RA(config-if)# no sh
RA(config)# int s0/0/0
RA(config-if)# ip add 172.31.4.1 255.255.255.252
RA(config-if)# no sh
RA(config)# router ospf 1
RA(config-router)# router-id 1.1.1.1
RA(config-router)# network 172.31.0.0 0.0.1.255 area 0
RA(config-router)# network 172.31.4.0 0.0.0.3 area 0
RA(config-router)#passive-interface g0/0

RB

RB(config)# int g0/0
RB(config-if)# ip add 172.31.2.1 255.255.254.0
RB(config-if)# ipv6 address 2001:DB8:1::1/64
RB(config-if)# ipv6 address| FE80::1 link-local
RB(config-if)# no sh
RB(config-if)# int s0/0/0
RB(config-if)# int s0/0/0
RB(config-if)# ip add 172.31.4.2 255.255.255.252
RB(config-if)# no sh
RB(config-if)# int s0/0/1
RB(config-if)# ipv6 address 2001:DB8:2::1/64
RB(config-if)# no sh
RB(config)# router ospf 1
RB(config-router)# router-id 2.2.2.2
RB(config-router)# network 172.31.4.0 0.0.0.3 area 0
RB(config-router)# network 172.31.2.0 0.0.1.255 area 0
RB(config-router)# passive-interface g0/0
RB(config)# ipv6 unicast-routing|
RB(config)# ipv6 router ospf 1
RB(config-rtr)# router-id 2.2.2.2
RB(config)# int g0/0
RB(config-if)# ipv6 ospf 1 area 0
RB(config-if)# int s0/0/1
RB(config-if)# ipv6 ospf 1 area 0

RC

RC(config)# ipv6 unicast-routing
RC(config)# ipv6 router ospf 1
RC(config)# int g0/0
RC(config-if)# ipv6 add 2001:DB8:3::1/64
RC(config-if)# ipv6 address| FE80::3 link-local
RC(config-if)# ipv6 ospf 1 area 0
RC(config-if)# no sh
RC(config)# int s0/0/0
RC(config-if)# ipv6 add 2001:DB8:2::2/64
RC(config-if)# ipv6 ospf 1 area 0
RC(config-if)# no sh

PCA

IP address: 172.31.1.254
Subnet mask: 255.255.254.0
Default Gateway: 172.31.0.1

PCB

IP address: 172.31.3.254
Subnet mask: 255.255.254.0
Default Gateway: 172.31.2.1
IP6 address: 2001:DB8:1::2/64
IPv6 Gateway: FE80i::1

PCC

IP6 address: 2001:DB8:3::2/64
IPv6 Gateway: FE80::3
#  CCNA2